Schmitronic

Réparations d'appareils électroniques vintage



Restauration d'un 5ème Disco

Et de 5 ! Je ne reviens plus sur les actions de maintenance. Voici les quelques pannes inhabituelles que j'ai résolues sur cette machine.

Le phonographe est bloqué sur le châssis : une roulette sous le charriot est sortie de son rail de guidage. En forçant un peu la lame de pression, la roulette se remet en place. Le charriot a dû subir un sacré choc pour "sortir ainsi de ses rails" !

Le mécanisme de blocage/déblocage du bras de lecture ne bouge pas, il me faut démonter tout le bloc pour dégripper le mécanisme. Je dois également relever la lame de roulement d'amenée du disque  car elle bloquait aussi la libération du bras.

Je recolle l'aimant de fin de disque tombé avec de la colle Loctite. Pour la première fois je tombe sur un contact "reed" cassé, heureusement j'en ai de la même dimension et sensibilité. Il m'est donc facile de le remplacer, mais cela me prendra un certain temps pour régler la position correcte.

Après la maintenance de l'ampli, je teste l'audio, cela fonctionne correctement sur les faces A mais pas sur les faces B, le son est horrible. Je regarde l'aiguille et à la place du diamant, je vois un ... fil ! La créativité de certains n'a pas de limites ! Je remplace vite cette aiguille un peu trop originale et qui abime surement très vite les disques.

L'aiguille la plus rock'n'roll du monde : un fil !

La mécanique et l'audio fonctionnent, mais pas le système de sélection. L'affichage est OK, le mode test également, le monnayeur aussi, mais le clavier ne répond quasi pas et bien sûr le phonographe ne démarre pas. Le boitier "microprocesseur" contient 3 cartes empilées les unes sur les autres (contrôleur, crédit, clavier/afficheurs). Ce boitier communique encore avec une 4ème carte d'interface située dans un châssis séparé qui contient les alimentations. Ces 4 cartes sont très compactes, les pannes sont réputées difficiles à diagnostiquer et le travail difficile, au vu de la fragilité des pistes et leurs compacités. Pour le clavier, d'après les combinaisons qio fonctionnent, je devine que c'est l'IC U7 (4584 hex trigger) qui est mort, je le remplace et c'est bien cela. Vu le manque d'espace on ne peut même pas souder un support tulipe, je suis obligé de ressouder l'IC directement sur la carte. Je rajoute un jeu de piles extérieur pour conserver les crédits, le phonographe démarre ...

... Mais il ne sélectionne pas. A chaque inversion de marche, l'afficheur indique 100 et 179 mais ne bouge pas en milieu de scan ! Je revérifie sur des vidéos internet, l'afficheur compte et affiche toutes les positions de charriot en temps réel, mais pas ici : il ne compte pas ! Je vérifie tous les signaux entre la carte d'interface et la CPU avec une sonde logique (limite 100, limite 179, compteur incrémental, compteur décrémental, face B, moteur A et moteur B), ils sont tous OK. Donc la MPU reçoit bien les impulsions de comptage dans les 2 sens mais il ne les affiche pas et ne sélectionne rien ... sauf les sélections 100, 179, 200 et 279 ! Logique, puisque le microprocesseur reçoit ces 4 positions extrêmes via les 2 contacteurs de fin de course et pas via les lignes de comptage. Donc l'essentiel de la carte MPU fonctionne et ces symptômes et comportements très précis vont beaucoup m'aider pour le diagnostic. J'ai dû imprimer le schéma au format A2 pour arriver à le lire ! L'extrait du schéma ci-dessous décrit les circuits d'entrées et de comptages.

Extrait de la partie du schéma qui décrit le comptage de position du chariot

Le principe est simple (si, si !) : il faut convertir des positions et impulsions en un nombre entre 00 et 79 qu'il faut transmettre au microprocesseur via un bus à 8 bits quand le processeur le demande. La partie comptage, de gauche à droite :

Donc, tous les circuits vert, rouge et jaune fonctionnent, seuls les circuits bleus ne fonctionnent pas. Comme les fonctions de Clear et Load fonctionnent sur les 2 compteurs, je suppose que ces 2 ICs sont bons. Comme je doute que les 2 transistors aient claqué en même temps, il ne me reste qu'à mettre en cause U33 (4584 hex trigger). Je le remplace mais c'est galère (foutue carte) ... et rien ne change ! Caramba, encore raté ! Donc ça ne peut plus être que le premier compteur U31, son remplacement est encore plus difficile (voir photo), je suis obligé de ressouder sous la carte 6 fils pour refaire les pistes cassées.

Quel chantier après enlèvement de U31 ...

Travailler sur le contrôleur du Disco est pénible : en plus de la difficulté à remplacer les circuits intégrés, il est délicat de rempiler les 3 cartes, puis de les remonter dans la boitier (l'afficheur est en verre !), ensuite remonter le boitier avec ces 4 petites vis dans une position impossible (par en-dessous du panneau avant soulevé) sans foirer le pas de vis, et finir par insérer les 3 petits connecteurs qui sont difficiles à remettre car ils sont petits et on n'a pas de visibilité.

J'essaie et ce n'est toujours pas bon ... désespérant ... mais le comportement est différent : il affiche 100 ou 200 tout le temps ! Je laisse tomber quelques jours puis je redémonte le boitier encore une fois. Cette fois j'alimente la carte au banc d'essai, installe des interrupteurs aux 4 entrées et simule les impulsions. Je mesure les entrées et sorties des divers circuits avec une sonde logique et je détecte une piste coupée à l'entrée 1 de U33 (circuit rouge), donc le Clear était actif tout le temps : les 2 compteurs était en reset permanent (0 partout) d'où l'affichage 100 ou 200. Je corrige cela et remonte le tout et ... bingo ça marche ! Halleluja !

Pendant les tests, certaines sélections ne se font pas (x78 et x79), ou il prend "à coté" (101 au lieu de 100), ou le scan ne démarre pas à tous les coups (il faut laisser le doigt sur le dernier chiffre de la sélection) ! Je passe un certain temps pour bien régler et positionner les doubles contacts de fin de course. Ils étaient mal réglés et les lames intérieures des 2 contacts touchaient les butées métalliques et provoquaient un petit court-circuit sur l'alimentation 12V à chaque fin de course ! En suivant les instructions de la documentation tout rentre dans l'ordre. J'ai l'impression que quelqu'un a plié les lames pour faire toucher la roulette contre le châssis, ce qui n'est pas le cas !

Après réglage, la roulette ne touche pas le châssis et la lame intérieure ne touche jamais la butée

Bizarrement en "descendant" toutes les sélections se font sans problème alors qu'en "montant" certaines sélections ne se font pas, jamais ... Peu importe la face choisie. Pour comprendre, je suis obligé de tester toutes les sélections : x06, x07, x22, x23, x38, x39, x42, x43, x54, x55, x78, x79 ! Une drôle de séquence, mais il y a une séquence : 2 unités consécutives qui commencent par un chiffre pair. On dirait une question de test de QI ! Dès qu'une de ces sélections est tapée au clavier, il scanne, ne trouve pas et ne s'arrête jamais ! Je dois enlever la pile pour lui faire oublier les sélections enregistrées !

Je me gratte la tête un bon moment et je ne vois pas la logique ! Finalement notre expert Thierry04 me met sur la piste : les 2 mémoires RAM de maintien (5101) sont souvent mortes et provoquent des sélections très bizarres. Je redémonte une fois de plus ce boitier MPU bien trop compact, quelle galère. Sur la carte je vois qu'une des RAM a déjà été remplacée et le gars a ressoudé directement le chip sur la carte ! Argh, ces circuits imprimés sont déjà très très fragiles, un 2ème dessoudage va être quasi impossible ... pfff alors qu'il aurait été si simple de ressouder un support tulipe qui permettrait de remplacer la mémoire en 2 secondes. Avant de m'y mettre je me demande si toutes les pistes autour de cette RAM sont bien ressoudées. Après quelques minutes de mesures systématiques, pin après pin, je trouve un défaut de continuité, je vérifie 10 fois qu'il n'y a aucun passage ... yes ! La ligne d'adresse A6 qui relie la pin 24 du microprocesseur à la pin 6 de la RAM est coupée ! Evidemment, ça doit marcher moins bien du coup ! Je soude un petit fil pour refaire la liaison, remonte fébrilement le boitier, et youpie les sélections montantes sont prises à nouveau ! C'est quand bizarre de constater que l'enregistrement de la même sélection n'était pas enregistrée dans le même emplacement mémoire si le phonographe incrémente ou décrémente ! Je serais curieux de voir le code du programme de cette machine. Il est réputé plein de bugs et mal foutu ...

Voilà, c'est la première fois que je dois remplacer et réparer autant de choses dans ces foutues MPU. Pas facile, mais on a évité de remettre une unité centrale neuve ... et onéreuse.


6ème Disco

Machine en bon état, mais la MCU déconne ... comme d'habitude. Je commence par remplacer les 3 connecteurs car les fils cassent et les cosses sont oxydées. Au démarrage, tout ce passe parfaitement ... pendant 2 minutes ! L'affichage fait n'importe quoi, le phono aussi. Je soupçonne d'emblée les RAMs 5101. La carte MCU est propre et c'est même la toute dernière version de Stern, les RAMs sont sur supports, super pour l'échange. Mais rien à faire la machine déconne toujours autant. D'ailleurs les RAMs d'origine fonctionnent très bien sur une CPU de flipper ! Donc ce n'est pas ça. Je vérifie tous les signaux d'entrée et la carte interface, tout est OK.

Je dois admettre que je suis fatigué de cette MPU des discos, mal conçue et aucunement fiable, tous les techniciens sur la toile vous le diront. Finalement nous décidons d'acheter la carte GEN2MCU de Ron Rich. C'est cher, surtout au vu des taxes d'importation, frais de douanes et TVA (84 euros pour un achat de 300 euros !), mais au moins ça marche. De fait, je branche et hop c'est parti sans aucune erreur ! Comme quoi les MCU d'origine sont vraiment pourries. Ron Rich me prévient que, suite à la pénurie de composants due au Covid, il n'a pu obtenir que des afficheurs rouges pour les 2 digits de crédits. Pas de souci. Mais lorsque je teste avec le boitier en place, ces 2 digits sont invisibles ! J'avais oublié qu'il y a un filtre bleu sur le panneau. Rouge à travers bleu ne donne pas grand chose. Je remplace ce filtre bleu par un filtre rouge et le problème est résolu.

Affichage tricolore

L'ampli fonctionne, mais un canal chauffe. Le bias est à 1,9V, je le réduis à 1,6V et le souci est résolu. Les contacteurs de tonalité ne fonctionnent pas correctement. Je ris en découvrant l'arrière du préampli : les bornes des contacteurs ont été court-circuitées par du fil à souder ! Original ! Cela doit être dur à faire finalement. Après décrassage approfondi des contacteurs de tonalité, le son reprend vie ... à tel point qu'on entend une résonance sourde due au moteur du phonographe. Étonnement le silent bloc de soutien inférieur du moteur est toujours présent, je l'enlève et la résonance disparait.

Les soudures 100% fil d'étain !

A la demande du client j'ajoute un module Bluetooth (comme déjà réalisé sur un Wurlitzer Americana). Il est possible de monter les sorties BT en parallèle sur les entrées audio, il n'y a pas de souci d'impédance à condition de couper l'alimentation du BT en mode jukebox. Je monte un contacteur qui dans une position alimente le module BT et dans l'autre coupe l'alimentation du relais de mute. En effet, lorsque le juke box est à l'arrêt, le relais de mute est actif et les entrées sont court-circuitées à la masse. Comme l'ampli est équipé d'un préampli RIAA, il faut étouffer les basses du BT. Le plus simple est d'insérer des condensateurs en série dans les signaux qui arrivent du BT pour réaliser un filtre passe-haut qui simule assez bien l'inverse de la courbe RIAA nécessaire. A l'essai, je dois rajouter un potentiomètre de volume d'entrée du BT car le niveau est trop puissant. Les condensateurs qui donnent le meilleur son sont des 470nF. C'est très différent du montage réalisé dans le Wurlitzer : pas de potentiomètre, il a suffit de condensateurs de 1nF pour obtenir la bonne tonalité et le bon niveau, mais ce n'était pas non plus le même modèle de module BT.

Montage propre et discret avec utilisation des trous existants du chassis !

Et voilà un disco ressuscité et fiable comme il ne l'a jamais été.

Restauration du 1er Disco

Restauration du 2ème Disco

Restauration du 3ème Disco

Restauration du 4ème Disco