CSPROJECTS

Réparations d'appareils électroniques vintage



Réparations d'un 2ème Seeburg Mardi-Gras ... et d'un 3ème

Arrive un Mardi-Gras, c’est le 2ème (voir le 1er ici) mais celui-ci est un peu spécial. Une présentatrice connue de la télévision a souhaité offrir un juke box à son conjoint en guise de cadeau d'anniversaire surprise. Et comment fait-on pour trouver un cadeau aussi original ? On utilise Google, on tape "juke box" … et on tombe sur mon site ! Elle demande un avis à ses collègues ingénieurs du son qui lui confirment que j'ai l'air de m'y connaitre. Elle a confiance, prend contact avec le partenaire pour qui je répare et commande la machine. Elle devra être livrée à l'occasion de la fête qu'elle organise avec les collègues de la chaine de TV. Il est même prévu qu'ils amènent chacun un 45 tours en cadeau pour charger la machine ! Le juke box a intérêt à fonctionner nickel, vu les professionnels qui vont l'écouter ! Mais j'ai à peine un mois, je commence déjà à être nerveux …

La caisse a été nettoyée et restaurée par mon partenaire mais à l'intérieur elle ne contient quasi que le phonographe ! Il manque le contrôleur, et l’amplificateur audio n’a plus que la moitié de ses transistors de puissance, je vais devoir puiser dans mon stock et réparer 2 châssis. Mon inquiétude monte d'un cran …

La machine reçue est propre, mais vide ! Il y avait quand même le phonographe et l'amplificateur que j'ai déjà déposés !

Le phonographe (Episode 1)

Le phonographe, même après l'avoir huilé, reste très dur à faire tourner et à un moment dans le mouvement il y a un claquage inquiétant. Un ressort an bout de l’arbre à cames est cassé (mais vite remplacé), ce n'est pas bon signe non plus. J'ai aussi trouvé une pièce de 5 FB dans le mécanisme ... stress en augmentation …

La lame de levée du disque bloque et ne monte pas dans le panier, elle est bien droite pourtant. J'ai fait le test constructeur de la position du panier et il est mal placé de 3 mm ! Il est impossible de placer un disque et depuis longtemps, car j'ai eu un mal fou à faire glisser le panier (dégrippant et coups de marteau). Comment est-il possible que ce phonographe soit si déréglé ? Je règle au mieux le panier à disques, ça marche, il prend bien les disques. Mais cela reste bizarre, car d'autres réglages doivent être modifiés pareil : les rampes des lampes sélection et de la mémoire Tormat ... je me demande si le phonographe n'a pas un souci et que c'est pour cela qu'il ne tourne pas à la main.

L’aimant de fin de disque a été perdu par mon partenaire lors du nettoyage … je colle un aimant non conforme. Mais comme il n’a pas la même forme ni la même puissance, le réglage est difficile, je dois placer le contacteur Reed dans une position totalement différente pour avoir un déclenchement plus ou moins correct. Plus tard, je trouverai un aimant conforme Seeburg sur un vieux phonographe et le mettrai à la place. Heureusement car les aimants originaux sont impossible à trouver et des aimants différents ne permettent pas de faire un réglage assez correct avec le contact Reed. D’autres contacts doivent être sérieusement décrassés, ne faisant plus aucun contact. Pas mal encrassée cette machine.

Le contrôleur

Je répare un châssis contrôleur provenant de mon stock, j'ai une différence entre alimentations de 15,4V, et il est bien connu qu'à plus de 15,5V les boites noires et grises claquent ! En échangeant des cartes entre châssis et en remplaçant bon nombre de composants, j'en remonte un qui se stabilise à 14,4V. Je teste le châssis au banc d’essai, le thyristor de détection mémoire déclenche très bien avec une pile de 1,5V, le relais suit bien également.

Je monte le phonographe, le contrôleur et les 2 boites dans la machine, remplace quelques ampoules et démarre la machine. Elle fait un scan, une sélection correcte, une prise de disque, puis plus aucune sélection n’est possible ! Le thyristor de détection mémoire a claqué à la première sélection dans la machine ! Je le remplace par un bon vieux 2N5060 et depuis c’est OK. Bizarre, stress ...

La sélection

Je nettoie et règle le clavier, la touche 2 réagit et allume la lampe 1er chiffre, mais au 3ème chiffre, le phonographe ne démarre pas en scan ! Alors qu'en faces A ça marche. Les touches 5, 8 et 9 font avancer la séquence mais je constate que le disque sélectionné n’est pas le bon. Cela sent la ligne data B qui ne fonctionne pas. La consultation des schémas confirme le souci, j’ai néanmoins l’impression que les boites noire et grise fonctionnent, il ne reste que la possibilité d’un problème de contact ou de carte buffer dans le contrôleur. Et de fait en échangeant la carte buffer, le problème disparait. Je vérifie la carte originale, redresse un transistor, nettoie le connecteur, remets la carte originale dans la machine … et ça marche ! Faux contact de connecteur sans doute ... stress.

L'amplification audio (Phase "claquage")

J’attaque l’ampli, tout l'étage de puissance d'un canal est cramé, il me faut remplacer les 2 transistors 2N3055 de puissance, une résistance de puissance et un transistor driver TIP41. Et pour faire bonne mesure je remplace les 3 condensateurs de filtrage de l’alimentation. Je reçois les nouvelles aiguilles commandées aux USA, remonte le tout, vérifie les haut-parleurs … mais le son est affreux : distorsion, résonance, déséquilibre stéréo, faux contacts (tonalité) ... pfff, les soucis sont nombreux et le temps est compté.

Pour être sûr de tester dans les bonnes conditions, j'isole déjà la partie aiguilles, cellule, connecteurs, câble coaxial ... en attaquant directement l'ampli avec mon Smartphone et de la musique mp3 corrigée en RIAA (voir explications dans la page outils).

Malgré cet ampli original réparé, je l'échange, mais les 2 amplis suivants chauffent de suite en canal droit, le 3ème ne chauffe pas, mais le son à droite reste mauvais (faiblesse du volume et grésillements aigus malgré un tweeter testé en parfait état). Au banc d'essai les 4 amplis sont pourtant bons. A un moment le 4ème ampli claque ... à droite évidemment ! Les 2 transistors de puissance et une résistance sont grillées, didju ! Mesurées en continu, les impédances des 2 voies stéréo sont OK, le "clic" à la pile est ok, sauf qu'à droite les aigües sont moins fortes. Il ne reste donc plus que le filtre crossover des tweeters à vérifier. Bizarre.

Le filtre se trouve dans un petit boitier caché en fond de caisse, démonté, il y a plus de composants que je ne pensais (les Wurlitzers ont juste un condensateur à côté du HP). Ici on a un condensateur, une résistance de puissance et une bobine ! Tout cela n'est mentionné dans aucun plan ! Je vois qu'une bobine a le papier de protection noirci et à l'ohmmètre l'appareil confirme qu'elle est bien claquée en court-circuit ! Elle fait partie d'un circuit passe-haut du 2ème ordre et donc le condensateur d'entrée en série m'empêchait de mesurer ce court-circuit à partir de l'extérieur. On a bien une impédance (en alternatif donc) nulle. Au repos, tout est OK, dès qu'on envoie le signal sonore, court-circuit pour l'ampli !

Vicieux et extrêmement rare, comment cette bobine a-t-elle pu être grillée ainsi ? Comme il n'y a rien dans les plans, c'était difficile de deviner une cornichonnerie pareille. Ces bobines sont manifestement sous dimensionnées, une toute grosse erreur de design de seeburg, pas mal d'amplis sont sans doute partis en fumée à cause de cela et beaucoup de techniciens n'ont probablement jamais réussi à faire le diagnostic ! Ils remplaçaient l'ampli, voire les haut-parleurs ... et reclaquage à court-terme !

Une recherche rapide sur internet pour remplacer tout le boitier ne donne pas grand-chose … Bon, alors il faut remplacer la bobine. Le souci est que sans plan, je ne connais pas les valeurs, seule la valeur du condensateur est connue. Les bobines de ce type (ou meilleures) sont très difficiles à trouver à la bonne valeur. Je peux recalculer le filtre mais je dois absolument connaitre la fréquence de coupure inférieure des tweeters. Si jamais trop de basses arrivent dedans, ils claqueront rapidement, et si je suis trop haut, on perd une partie de la bande passante. Jamais évident ce genre de choses, et en plus il faut être symétrique avec l'autre canal.


Calcul filtre 2ème ordre LC

Données connues :

  • Condensateur non polarisé de 7,5µF
  • Impédance du Tweeter 12 ohms, du  Woofer 4 ohms, puissance max 50 Wrms
  • Bobine crossover :
    • bobinage de 134 tours ; poids  de 4 grammes ; diamètre 12 mm; longueur 12 mm;
    • je déroule la bobine : longueur fil de 4 m ; diamètre fil 0,3 mm (AVG 31)
    • résistance 4 ohms (mesurée sur l'autre bobine)
    • perméabilité magnétique relative µr = 10.000 (estimation fer feuilleté)

Plusieurs calculateurs (surtout electrodroid, voir page applications pour smartphones) permettent de calculer une inductance d'à peu près 2,1 mH.

Les calculateurs de filtre passe haut du second ordre LC, pour un condensateur de 7,5µF donnent :

  1. 880 Hz, 3,3 mH (Linkwitz-Riley crossovers match attenuation slopes so that system response is flat at crossover point)
  2. 1.250 Hz, 2,1 mH (Butterworth crossovers yield to a peak at the crossover frequency)
  3. 1.020 Hz, 3,2 mH (Bessel crossovers have a frequency response between Linkwitz-Riley and Butterworth crossovers)

Mais bon, cela reste très empirique et pas évident à trouver sur internet, le plus simple et le plus rapide a été de la rebobiner à la main moi-même ! Les 4 m de fil n'ont pas été bien long à bobiner ... et cela fonctionne très bien.

A gauche, on voit la bobine noircie, vers la droite démontage, rebobinage, mesure

Un peu plus tard, je me rappelle que j’ai un testeur de composants capable de mesurer ... l'inductance des bobines ! J’aurais pu y penser plus tôt ! La bobine originale fait 1,22 mH et la bobine refaite 1,17 mH ! Pas mal, mais c’est normal : 4 m de fil remplacé par 4 m de fil du même diamètre sur le même support ne peut que donner des résultats similaires. La valeur simulée est un peu différente, mais dans le même ordre de grandeur quand même.

Encore un peu plus tard, par hasard, en feuilletant le manuel, je tombe sur le chapitre des connexions des haut-parleurs extérieurs supplémentaires et je tombe sur un schéma avec un filtre très similaire au filtre intérieur : 7µF au lieu de 7,5µF, 56 ohms pour la résistance dans les 2 cas ... et 1,5mH pour la bobine ! Ce document confirme donc mon calcul et la mesure.


L'amplification audio (Phase "son pourri")

La partie audio ne crame plus, mais la qualité du son n'est toujours pas correcte pour autant surtout sur le canal droit (mon stress augmente car les journées passent). En fait, il n'y a que les haut-parleurs qui sont ok des 2 côtés !

Resserrer ou échanger ces cosses n'est pas une mince affaire, car c'est très petit et donc délicat. Les quatre cosses sont maintenues dans un bloc plastique et fixées à l’arrière par une plaquette ronde en plastique maintenue par une vis. Les fils y sont soudés mais sont tellement fins qu’ils finissent par casser. Les cosses sont tellement petites que j’en perds une ! Elles sont noires d’oxydation et pas faciles à décrasser, la seule opération praticable est de resserrer chaque cosse avec une petite pince plate. Le plus dur est de remettre les 4 cosses dans leurs alvéoles et de revisser la plaquette de maintien. J’apprendrai plus tard dans le livre de Ron Rich qu’il faut desserrer la vis mais pas l’enlever, et sortir et remettre chaque cosse séparément en biais.

Gros plan sur le connecteur de de la tête de lecture

Après il faut ressouder les 4 fils microscopiques. Ils se sont tous cassés et j'ai dû les tirer à travers le bras pour avoir du mou et permettre de les ressouder. Après remontage les contacts sont bons, mais le bras dérape sur les faces A à cause du déplacement de la torsade de fils dans la mécanique. J'ai dû tirer et déplacer les fils. Pas marrant, c’est un travail délicat et long pour éliminer de simples faux contacts.

Le phonographe (Episode 2)

Enfin le son est bon. Mais le phonographe déconne : les sélections sont très aléatoires et les réglages habituels ne changent rien. Parfois, il ne prend rien, parfois le disque 100 se bloque entre le phonographe et le panier ! Le fait d’avoir dû translater le panier à disque m’intrigue toujours … et le stress monte car il ne reste plus beaucoup de temps et la machine n’est pas fiable. Je préviens mon partenaire qu’il serait sage de prévoir un plan B pour cette livraison importante et imminente. Il me répond qu’il s’en doutait mais que la chance lui a souri : il a trouvé un autre Mardi-Gras en état de fonctionnement, il l’a déjà acheté, il est dans le camion et il vient me le livrer !

Très bien, mais à l’allumage je découvre quand même quelques problèmes sérieux à cette machine annoncée en bon état. Voir la restauration de cette machine plus bas. Je décide d’échanger les phonographes entre les 2 machines.

La transplantation des phonographes (Episode 3)

Donc je sors le phonographe du dernier Mardi-Gras livré (le 3ème) et le teste au banc d'essai : il "chevrote" ! J'essaie d'améliorer la stabilité de rotation en le huilant bien, puis en essayant avec d'autres vieux coupleurs que j'ai sous la main, en ouvrant et en huilant les billes d'acier en bouts d'axes (il y en a 3). Rien à faire, il me faut commander en urgence un nouveau coupleur neuf plus souple. Ce nouveau coupleur résoud le problème, mais il me faudra un peu de temps pour bien rerégler le serrage des 3 billes. Le truc est qu'il doit rester un très léger jeu.

Après nettoyage des rampes de lampes et de la mémoire Tormat, il me reste à nettoyer les aiguilles, à régler les ressorts de pression des faces A et B et à équilibrer le bras avec la grosse mollette en dessous. Ouf, cette fois, la machine est stable et prête.

Je continue avec la machine 3 contenant le phonographe du 2. Si 2 machines sont opérationnelles pour la livraison, c'est d'autant plus sûr.

Le résultat final



Mardi-Gras 3

A l'origine la machine est fonctionnelle mais pas du tout au point : l’ampli fait un bruit de fond et le phonographe « chevrote » comme déjà expliqué !

Pour l’ampli, je remplace les condensateurs de filtrage, sans succès. Le bruit de fond provient d'une résistance, condensateur ou semi-conducteur, difficile de trouver la source, car le bruit se retrouve sur toutes les liaisons, je mets un autre ampli réparé de mon stock. La partie audio est maintenant OK. Il s’avèrera que c’était le transistor driver Q14 qui provoquait le bruit dans un canal.

La carte buffer du contrôleur est cassée et mal montée, je la remplace, une autre petite carte brinquebalait, je la fixe … quelle misère.

Le clavier est mal en point également : il a pris l’humidité, mais après nettoyage tous les chiffres envoient leur signal correctement, la boite noire réagit normalement, les ampoules 1er et 2ème chiffres s’allument et le scan démarre.

Comme expliqué plus haut, j'ai échangé les phonographes. Je récupère donc le phonographe totalement instable du Mardi-Gras 2. Pour rappel, j’ai bizarrement dû déplacer le panier à disque et aussi retrouver un aimant de fin de course. Je reprends tout à zéro.

L'aiguille dérape sur les faces B, je remplace le ressort, finalement je remplacerai les 2 ressorts. Le réglage d'équilibrage du bras avec la grosse molette sous le panier mobile est aussi à régler de manière précise pour avoir un mouvement d'aiguille sûr.

Dans le contrôleur, la bobine d'arrêt phonographe déclenche tard, le chariot s'arrête parfois au milieu ! Cela ne pose pas de problème en soi, mais ça fait bizarre. Le plongeur de la bobine "colle" un peu, un petit nettoyage, réglage et un peu d'huile fine dans les pièces mobiles et c'est reparti.

Suite à des tests systématiques (100, 111, 122, 133, …), je me rends compte qu'il ne sélectionne jamais les disques x5x, et encore certaines autres sélections mais de manière plus aléatoire. Ce sont 2 problèmes différents. J'échange la boite grise avec mon dernier exemplaire de stock et la machine sélectionne maintenant bien les disques x5x ! Donc la sortie 5 des dizaines est morte dans la première boite grise. On verra cela plus tard.

Il ne reste plus que la non fiabilité des sélections à corriger, surtout en faces B. Je continue à penser depuis le début qu'il y a un souci avec le déplacement du panier à disque que j'ai dû faire au début pour débloquer le mécanisme. Le panier n'avait jamais bougé auparavant vu le mal que j'ai eu à desserrer les vis et la machine a fonctionné des années, pourquoi faudrait-il le translater de 3 mm pour débloquer le mécanisme ? J'ai dû ensuite modifier quasi tous les réglages d'usine (butées, rampes, …) pour arriver à faire fonctionner à peu près la machine. Quelque chose m'échappe.

J’explique mes soucis à mon partenaire qui avait nettoyé l’intérieur de la machine avant de me l’amener. « Nettoyé ? Passé l’aspirateur ? ». « Non, me dit-il, j’ai tout sorti et j’ai même enlevé le bloc phonographe du châssis pour avoir un meilleur accès et mieux le dégraisser. Et je l’ai remonté sans problème » Caramba ! Il ne faut jamais démonter partiellement la crémaillère et sortir le bloc phonographe. Pourquoi ? Parce qu’après il faut le repositionner dans la « bonne dent » sur la crémaillère. En effet, je vois de suite que le pas du panier à disques est de 6 mm et celui de la crémaillère est de 3 mm, donc il y a 2 positions de remontage possible mais il y en a qu'une seule qui soit la bonne ! C’était ça le problème, il l’a calé sur la mauvaise dent ! D’où tous mes soucis ! Parce que je ne savais pas cette action, j’ai faussé tous les réglages d’usine pour compenser l’erreur de remontage du phonographe sur sa crémaillère !

Je ressors le châssis, enlève partiellement la crémaillère et ressors le phonographe. Je repositionne le panier à disque dans la position d’usine et remets le phonographe dans les rails. Je teste s’il est bien positionné en essayant manuellement de charger un disque pour voir si le phonographe s’est placé dans la bonne dent. Et bien, ce n’est pas facile, j’ai dû m’y reprendre à 7 fois avant de tomber dans la bonne position ! Il me faudra un bon moment pour remettre toutes les butées et réglages comme à l’origine, et finalement les disques passent bien du 100 au 179, ouf ! Comme dit le proverbe : « faire et défaire c’est toujours travailler ! » mais quelle perte de temps d’avoir tout déréglé et de devoir essayer de remettre le tout correctement maintenant. Finalement, après beaucoup de patience et quand même d’énervement, je finis par rendre la machine à nouveau fiable.

Conclusion, il nous faudra mieux communiquer à l’avenir …

Finalement pour le jour J, les 2 machines sont opérationnelles, et la première machine livrée donnera entière satisfaction. Tout est bien qui finit bien, mais quel stress !

Une des 2 machines fonctionne avec le chenillard d'origine, l'autre a été remontée avec des guirlandes de Noël à LED.


Mardi-Gras, et de 4 !

J'effectue la maintenance habituelle, voir d'autres machines, je ne répète plus. Le problème original ici était la boite grise. Elle ne prenait pas les sélections des dizaines (x1x) donc 110, 111, 112, 113 ... et 210, 211, ... Comme mon stock de boites fonctionnelles est tombé à zéro, je suis bien obligé d'essayer de les réparer ! J'ai quelques boites grises et noires en panne, ce serait génial de pouvoir les réparer. Seeburg gardait jalousement le secret sur ces boites, encore aujourd'hui les manuels et schémas ne sont pas disponibles sur internet. Par contre, j'ai acheté un excellent bouquin écrit par Anthony J. Miller qui a travaillé chez Seeburg et qui explique le fonctionnement et publie tous les schémas de ces mystérieuses boites. D'emblée il faut savoir qu'il existe des circuits intégrés spécifiques Seeburg qui sont très très sensibles à l'électricité statique, A. J. Miller déconseille même de faire des mesures au multimètre sur les pattes de ces circuits, ouh là, il va falloir faire gaffe !

Le manuel de 200 pages et la carte de programmation matricielle
Le microcontrolleur magique et sensible

J'ouvre la boite, il y a 2 vis et des pattes plastiques un peu justes qui maintiennent les couvercles. Grâce au schéma j'identifie et remplace le thyristor SCS12 (2N5064) qui commande la programmation des dizaines dans la matrice tormat. Facile, je referme, les pattes plastiques sont très difficiles à remettre et je dois forcer un bon coup pour refermer la boîte. J'installe et redémarre ... plus rien ! Aucune sélection ne se fait ! Bouh grosse déprime, j'aurai claqué ces fameux circuits intégrés si sensibles ? Pas marrant, si on n'arrive plus à réparer ces boites ce sera bientôt la fin des juke boxes Seeburg de cette génération.

Détail de la carte de programmation matricielle

Après une bonne nuit de sommeil, je me décide à rouvrir cette foutue boite, on ne sait jamais. Ouverte, j'éclate de rire : en forçant la fermeture, j'ai cassé le coin du circuit imprimé et coupé 5 pistes ! Normal que plus rien ne fonctionne ! Je recolle la pièce cassée et ressoude les pistes, mais cette fois je casse toutes les pattes des couvercles et du coup la boite est très facile à fermer, les 2 vis suffisent amplement pour tenir le tout ensemble. A se demander si Seeburg ne l'a pas fait exprès pour rendre le dépannage difficile, mais peut-être que je deviens parano. Je remonte ... et ça marche !!! Yahoo ! En testant, je me rends compte qu'il y a une 2ème panne sur cette boite : pas de sélections avec l'unité 9 (xx9 : 109, 119, 209, ...). Je rouvre encore une fois cette boite, remplace le thyristor de commande (SCSxx) des unités 9 et hop elle fonctionne enfin à 100%.

Le partie cassée et la réparation

Tant que je gagne, je joue ! J'ai commencé à réparer toutes les boites  en panne. J'en ai ouvert une dont les pattes des couvercles avaient déjà été cassées et qui ne faisait pas les x7x. Je remplace le thyristor (SCS18), j'essaie ... mais cela ne marche pas ! Je nettoie les pistes du connecteur (bien ternes) et détecte une coupure de piste quasi invisible. Je ressoude et hop ça marche ! Une 2ème boite grise de sauvée !

Ensuite les réparations s'enchainent ... pour les boites grises :

Pour les boites noires :

Vue des 3 cartes de la boite noire avec les 2 microcontrolleur spéciaux

Accès à l'article sur le premier Mardi-Gras