CSPROJECTS

Réparations d'appareils électroniques vintage



Restauration d'une borne d'arcade type Pacman (1981)

Je n’ai jamais été intéressé par les jeux vidéo (sauf « Elite » sur ordinateur BBC Acorn), car pour moi c’est beaucoup trop statique par rapport à un flipper. Après insistance de la part d’un propriétaire qui a acheté une borne d’arcade dans une brocante, j’accepte quand même de jeter un coup d’œil à sa machine. Elle est d'origine italienne au vu d’une étiquette sur un connecteur, mais je ne trouve aucune marque ni identifiant ! Le jeu s’appelle « Ghost » et fait penser à un Pacman. Aucune existence sur internet … ça commence bien.

Des fils sont coupés, un condensateur de filtrage pendouille dans un coin, il y a de grosses traces de brûlure au-dessus du radiateur du régulateur de tension, le connecteur est affreux, … A l’allumage, l’écran s’illumine une fois sur deux, affiche les petits Pacmans une fraction de seconde puis affiche des caractères et des petits carrés de couleur, à la façon du film « Matrix », puis revient à l’écran normal, puis à Matrix …. Pas terrible, mais au moins le tube TV et sa platine fonctionnent au moins je n’aurai pas à bidouiller dans le circuit haute tension. Pas de réactions aux monnayeurs, boutons et manette et pas de son, pas d’éclairage non plus.

intérieur Pacman

Le connecteur doit aussi avoir un problème, car parfois l’écran ne s’allume pas du tout. Je décrasse et re-étame les pistes, mais rien n’y fait. Sur l’envers du circuit imprimé se trouve une inscription « PAC/M », c’est donc bien une copie discrète du jeu japonais (Namco). En cherchant bien et sur le conseil d’un collègue passionné de jeu vidéo, je constate que la carte est très similaire au plan et conforme au manuel du vrai jeu de Pacman, au premier abord seul le circuit audio utilise un circuit intégré différent. Ouf. Au passage, je remonte le gros condensateur de filtrage correctement sur la carte.

Au premier abord je penche pour un problème d’EPROM, car je vois le programme qui démarre puis qui dérape, le tout en boucle. Je sors la carte, il y a 16 EPROMs des petites 2716, punaise, ils faisaient des miracles avec 3 fois rien (ici 32kb). Je les sors toutes une à une et les teste avec mon petit programmateur, j’en profite pour conserver une copie du contenu. Elles sont toutes bonnes et les supports ont tous l’air en parfait état. Cela me change des supports foireux qu’on trouve sur les cartes de flippers.

A l’oscilloscope au banc d’essai, je vois bien le « clignotement » : les lignes des bus de données et d’adresses s’arrêtent toutes les 3 secondes.

Carte pacman

Bon, ce serait les RAMs alors ? J’y trouve des modèles que je ne connaissais pas (2114). Le super site de MikesArcade confirme mon hypothèse (voir 08/27/2000). Je commande des RAMs en Bulgarie, sans doute des copies russes de ces composants américains datant de l’époque de la guerre froide. J’ai déjà commandé pas mal de ces composants et n’ai eu aucun problème. Une fois reçus, j’échange les 6 RAMs, et au banc d’essai, les bus oscillent sans interruption, bon signe. Mais avec la carte remontée dans la machine, je n’obtiens qu’un écran noir … J’y crois pas, je bouge le connecteur et hourrah, l’écran d’entrée s’affiche, les crédits s’affichent également en activant le monnayeur et le jeu démarre : la fameuse image du labyrinthe bleu apparait et le petit rond jaune mange les points … en silence !

Après quelques temps, l’une ou l’autre couleur disparait, le bleu puis le vert, puis le rouge, … A chaque fois en tordant le connecteur, l’image revient. Un bête faux contact entre le connecteur et la plaque. Et bien non après mesures, toutes les connections sont bonnes. Réfléchir, toujours réfléchir … Le plan m’informe que les sorties vidéos couleur proviennent d’un petit circuit intégré appelé « PROM couleur » (74S288) d'une capacité extraordinaire de 256 bits ! En le regardant de près, toutes les pattes sont littéralement rouillées ! La puce fonctionne, mais des pattes sont cassées dans le support, ce n’était donc pas un problème dans le connecteur principal.

En sortant la puce, 4 pattes restent coincées dans le support ... et les autres tombent toutes seules comme des dents pourries ! Le problème est que ce circuit intégré est introuvable car programmé pour un jeu spécifique. Et très peu de gens ont l’équipement et la connaissance pour en reprogrammer. Il est également illusoire d’espérer en trouver une sur une autre machine, ces composants doivent tous être dans le même état avancé de décomposition.

Je n’ai plus rien à perdre : j’enlève les dernières pointes des pattes du circuit et je décape sous la grosse loupe et au stylo à la fibre de verre les épaulements des pattes qui s’avère être moins corrodés que les pattes. Je fixe le circuit dans une pince pour l’immobiliser et permettre une dissipation maximum de chaleur et je commence à souder sur les épaulements des bouts de fil rigides récupérés après montage de composants genre résistances. Je coupe les 14 fils à la même dimension, et ce n’est pas trop mal, ils sont tous à peu près droit, voir ci-dessous.

PROM couleur pacman avec pattes ressoudées
Résultat après "greffe" de fils pour remplacer les pattes. Le circuit fait 2 cm de long !

Le support a souffert, surtout quand j’ai dû aller récupérer les pointes de pattes dedans ! Mais tant pis j’essaie déjà comme cela, il sera toujours temps de le remplacer après si nécessaire.

Avec d’infinies précautions, je parviens à enficher le circuit. Je teste toutes les connections à l’ohmmètre, c’est bon. Je redémarre la machine et bingo, ça marche sans problème ! Voilà une machine qui revient de loin.

Reste le son. Les fils vers le haut-parleur sont coupés, le haut-parleur est bon. La sortie audio me donne un signal redressé mais alternatif de 7V, ça devait faire un sacré ronflement, d’où la coupure sans doute ! Le dépannage est facile : l’alimentation de l’ampli audio est bien continue mais n’est plus filtrée, il me suffit de remplacer le condensateur de filtrage, de recâbler et le son nasillard bien connu « scronch, scronch, scronch, … » retentit à nouveau !

Après ressoudure d'un fil sur le potentiomètre de contraste la machine est à nouveau 100 % opérationnelle.

Pacman avec éclairage

Pour finir je craque : il semble n’y avoir jamais eu d’éclairage derrière le bandeau supérieur et les monnayeurs, alors j’ai ajouté quelques LEDs, cela donne quand même beaucoup mieux non ?

Voilà donc une machine réparée malgré mon peu d’intérêt initial, mais je dois admettre que je me suis bien amusé ! Chouette découverte.


La borne en pleine action !

(CS décembre 2014)