CSPROJECTS

Réparations d'appareils électroniques vintage



Restauration d'un flipper Williams Demolition Man de 1994

Voici la 92ème machine que je répare et pourtant c'est la première avec un affichage dot matrix ! La machine est lourde, c'est un plateau large avec plein de gadgets et une électronique qui tapisse entièrement le fond du fronton !

Et bien, il y a du monde dans le fronton !

Par contre, il n'y a plus l'afficheur ... je le trouve dans le fond de la caisse. Je me doute qu'il a un problème, mais je le remonte néanmoins. Je vérifie l'alimentation particulière de l'afficheur, il y a 4 tensions : +5V, +65V, -115V et -128V ! Un condensateur (400V) a claqué ainsi qu'un fusible. Je remplace les composants défectueux et reconnecte le tout. Il faut avoir une différence de 12V entre les 2 tensions négatives, mais je n'ai que 5V. Même à vide, elle ne monte pas beaucoup plus haut. Je refais les soudures et remplace encore quelques composants douteux ou hors norme, l'écart de tension monte à 9V. L'afficheur s'allume mais fait des dessins fantômes, on devine les textes mais ils sont flous ! J'ai oublié de prendre une photo mais j'en ai trouvé une autre sur internet qui donne le même effet, voir ci-dessous. D'après les commentaires sur internet, il est difficile d'établir le diagnostic (afficheur ou alim ?), seule méthode sûre : tester avec une autre afficheur ! Encore faut-il en avoir un.

Gros plan sur l'alimentation de l'afficheur dot matrix

Cette alimentation est soumise à rude épreuve et est réputée fragile. Des kits de composants existent, ainsi que des mini-cartes "plug-in" à monter par dessus la carte originale. Comme la tension à vide n'est pas bonne, je commande d'abord la petite carte plugin, je n'ai pas le temps de commander les composants spéciaux, enlever les vieux et ressouder les neufs. Installée, l'afficheur ne fonctionne pas du tout ! Mais les tensions sont bonnes ... donc c'est bien l'afficheur qui est mort. J'en commande un nouveau, oufti c'est pas donné ! Mais ça marche ! On peut enfin commencer à voir se qui se passe et lancer la machine.

Effet similaire à l'ancien afficheur à gauche et le nouvel afficheur à droite

La machine fonctionne à peu près correctement, sauf qu'elle relance les 5 billes les unes derrière les autres ! Multiball permanent ! Le problème est vite résolu : la fiche qui se connecte à la carte qui supporte les 5 contacts de détection de billes derrière l'apron est tombée !

Un gadget unique est la présence de poignées sur les côtés au dessus du plateau, rappel de la machine du film. Aucun des 4 boutons ne fonctionne. En fait les fiches sont déconnectées. Je les rebranche et d'un côté le batteur se bloque en posiution haute et de l'autre la poignée active normalement le batteur, mais bizarrement le bouton normal ne fonctionne plus ! Je démonte le tout et étudie le schéma. Williams a fait sophistiqué. D'habitude les boutons de batteurs sont de simples contacts qui commandent directement les bobines des batteurs, simple et efficace, ça fait juste des étincelles vu les chocs de courants. Mais ici, il y a une carte de contrôle des batteurs (Flitronic) et le bouton active une languette plastique opaque qui de déplace devant 2 optocoupleurs. Par contre les poignées ont un contact électrique normal faible puissance. Il y a 2 entrées par batteur sur la carte Fliptronic et quand on insère le connecteur provenant de la poignée, le câblage change : une entrée voit le contact de poignée et l'autre voit l'opto du bouton.

A gauche, le batteur se lève uniquement quand je branche la poignée, c'est que le contact est fermé en permanence. Je démonte la poignée, le contact est bien fermé, je le dessoude et là il est ouvert ! Caramba, il y a un court circuit dans le câblage entre la poignée et le bouton du batteur ! Je démonte la partie de la poignée qui est fixée à la caisse et je voit les fils dans une gaine qui se faufilent entre des fentes dans le bloc de poignée et fini par être écrasé et faire court-circuit ! Il suffit de bien repositionner la gaine et les fils pour faire disparaitre le souci.

 A droite, c'est un des deux optos qui est mort et c'est la raison pour laquelle le bouton ne réagit plus lorsque la poignée est connectée. J'essaie d'échanger les optos, mais une patte casse ! J'en ai d'autres mais pas tout à fait du même type, j'essaie quand même mais cela ne marche pas, argh ! Bon un contact c'est un contact : j'enlève la carte avec les 2 optos coupleurs et j'installe un bon vieux contact à lames et hop problème parfaitement résolu ! Il faut rester pragmatique.

 Il reste encore à regarder aux 2 boutons poussoirs au dos des poignées, ils servent à lancer la bille et à obtenir des bonus en cours de partie. Je les démonte, c'est incroyable : le bouton rouge est un cylindre en plastique qui devrait coulisser et appuyer sur un petit contacteur poussoir dans la poignée, mais ils sont totalement bloqués ! Je doit frapper (fort) avec un chasse-goupille pour les sortir, alors qu'ils devraient tomber tout seul ! En fait, un peu de crasse mais surtout un gonflement du plastique (dû à la chaleur ou à l'âge) à fait se dilater le plastique. Il me faudra poncer sérieusement à la dremel ces 2 boutoniaux pour qu'ils coulissent à nouveau naturellement.

La poignée (photo internet)

Et voilà, il reste à régler quelques contacts et à remplacer quelques ampoules et on peut jouer ... mais il faut comprendre les règles du jeu ! Le plateau est très rapide et avec 5 billes on ne s'ennuie pas ! C'est assez marrant de jouer avec les poignées, j'aime le lancer de billes avec le poussoir arrière. La pince magnétique pilotée par les poignées est amusante aussi. La musique est celle du film, le rendu est excellent ! Très chouette machine, voir la vidéo ci-dessous.

En haut, les 9 rampes et passages de cet incroyable plateau !
"The Claw", la griffe aimantée qui maintient la bille et qu'on peut manœuvrer avec les boutons de batteur

La machine en cours de jeu, avec passage par la griffe qui maintient la bille


(CS octobre 2017)