CSPROJECTS

Réparations d'appareils électroniques vintage



Restauration d'un flipper Bally Night Rider (1976)

Cette fois, je reçois un Night Rider Bally à réparer, machine avec un chouette thème du genre « les routiers sont sympas », j’aime bien les lampes d’informations sur le fronton intégrées sous des panneaux de signalisations.

Le résultat en photos

Caisse, vitre et plateau sont en bon état, c’est moins le cas pour l’électronique. En effet, la batterie a encore fait des ravages, cette fois les composants de la région basse de la carte MPU offrent sur leurs fils une belle couleur cristallisée, verte comme de m’émeraude. Confirmation à la mise sous tension : rien, la LED ne bronche pas.

Tout d’abord, une mise à la terre sérieuse s’impose, la tresse de masse qui parcourt la machine a été coupée à plusieurs endroits : quand on n'est pas capable de trouver la cause, on supprime le symptôme ... Le fil d’alimentation 220V qui arrive à l’interrupteur d’allumage n’est même pas soudé, une simple boucle du fil dans l’œillet de la cosse de l’interrupteur n’encourage qu’aux faux contacts, voire à l'incendie .... Incroyable de fragiliser ainsi une électronique sensible alors qu’un coup de fer à souder prend à peine 2 minutes.

Après enlèvement de la batterie, la carte MPU passe au « card-wash » habituel : bain de vinaigre + eau + savon vaisselle, brossage ferme, rinçage et séchage au four de cuisine à 50° pendant 1 heure (ma femme fronce les sourcils à chaque fois). Les 2 transistors du circuit de reset tombent tout seul, rongés par l’alcalin ...

détail fronton flipper bally night rider

Le stylo à fibre de verre et la Dremel font merveille pour décrasser les pistes attaquées et je remplace les 4 connecteurs de la carte. Je vérifie tous les composants du circuit de reset et dois remplacer également la LED, étonnant. Je remplace le premier transistor (2N3904) mais je n’ai pas d’exemplaire du deuxième (2N4403). Je cherche un équivalent sur internet en fonction de ce que j’ai en stock … sans résultat. Le type original est un PNP à courant de collecteur max de 0,6A. Je finis pas trouver un PNP à Ic max de 1A dans mon vieux stock et tente le coup. La carte démarre ! Mais 2-3 flashes et de temps en temps, mais on avance. Des connexions directes par pinces crocodiles des alimentations améliorent un peu la consistance des flashes. N’ayant pas confiance dans la stabilité des vieilles alimentations dans la machine, je décide de m’en construire une de labo afin de pouvoir tester les cartes MPU à l’aise. Une alim de 12V + régulateur/capa suffisent pour démarrer un carte jusqu’aux 6ème flash, le 7ème n’étant pas possible en l’absence de 43V. Ce qui est amusant avec ce transistor non conforme dans le circuit de reset est que je ne vois plus le premier flash tellement il est court, mais le circuit de reset fait son job, le CPU démarre !

La carte démarre bien sur mon alim de labo mais avec un nombre variable de flashes, entre 2 et 6. Commence alors le remplacement de la RAM temporaire, de la RAM permanente, de l’échange des 2 PIA, du remplacement des PIA, le démarrage est maintenant systématique jusqu’au 3ème flash, ROM et RAMs sont donc OK. Le problème tourne autour du premier PIA, car parfois la carte démarre complètement en émettant les 6 flashes ! Les PIA sont donc bons puisqu'il démarre bien parfois … conclusion : faux contact intermittent ! Les pires pannes à diagnostiquer.

Commence alors le contrôle à l’ohmmètre de toutes les lignes du bus d’adressage et de données, je vérifie 2 fois depuis la broche sur le chip du microprocesseur jusqu'à la broche du PIA, rien à signaler, les contacts sont bons … je vois néanmoins à la base des supports de circuits intégrés que les pistes ont souffert et sont fines et blanchies par l’alcalin de la batterie. J’enlève et remets le PIA, fait ployer la carte électronique, et finalement la panne devient systématique, il n’émet plus que 3 flashes à chaque départ ! Et cette fois, je détecte une rupture franche d'une ligne d’adresse sous le support. Autant dire que l’accès est impossible, pas moyen de refaire une soudure avec le support en place. Il faudrait remplacer le support et dessouder les 40 pins de celui-ci, sur une carte double face affaiblie, c’est mission impossible … De plus, vu le temps imparti pour la réparation, il serait plus rapide et moins cher de remplacer complètement la carte. J’adopte la solution ultime, pas très propre il faut dire, mais très efficace : je soude délicatement un fil depuis la piste d’adresse concernée directement sur la broche du PIA ! Je n'ose pas mettre une photo ... mais la carte est maintenant fiable pour un bon moment.

La carte démarre à coup sûr avec mon alimentation de labo mais pas dans la machine, elle reboote souvent toute seule à la fin de la séquence. Je suis obligé de fiabiliser l’alimentation en remplaçant le connecteur, le régulateur, le condensateur de filtrage et en renforçant certaines pistes notoirement trop fines pour le courant à véhiculer. Cette fois le flipper démarre bien et on peut lancer le self test : je fais l’inventaire des lampes commandées mortes, afficheurs en déroute, bobines sans réactions, …

Les afficheurs vivent leur vie et affichent n’importe quoi au premier abord. A y regarder de plus près, je constate que les digits qui devraient être éteints, affichent « 7 ». De plus il n’affiche pas les « 8 » et les « 9 ». Cela sent le signal de commande d’affichage et le bit 4 en rade (voir dépannage du Harlem Globetrotters). Les bouchons de protection du téton de mise sous vide des verres d’afficheurs manquent, comme souvent, et avant de toucher aux circuits d’afficheurs et vu la fragilité de cette petite excroissance de verre, je recolle dessus un support caoutchouc de support de LED avec de la colle Patex. Je ressoude les connecteurs des 5 afficheurs, c’est fou les problèmes que cela résout, au minimum la stabilité d’affichage. Comme je dois aller vite, je ne remplace que les 2 cosses des lignes en défaut et immédiatement les « 7 » s’éteignent et les « 8 » et les « 9 » apparaissent, c’est magique !

Après remplacement des ampoules grillées et décrassage des sockets, il reste malgré tout beaucoup de lampes qui ne réagissent pas. Par déduction sur les schémas, je vois que les lampes manquantes ont en commun 2 des 4 lignes de données qui ne réagissent pas, pas étonnant que la moitié du plateau soit mort ! Deux cosses remplacées plus tard, l’arbre de Noël s’illumine à nouveau à plein feu.

Une des 4 notes du carillon ne sonne pas. Le diagnostic est vite fait, le papier autour de la bobine a un belle couleur brune, symptôme manifeste d’un échauffement mortel ayant entrainé également la fin de son transistor de commande ! Après achat d'une nouvelle bobine et remplacement du transistor pilote, la mélodie est à nouveau complète et cohérente.

Mon fournisseur habituel d’autocollants de porte (le losange Bally) et de plaquettes rétroéclairées (Bally Press Free Play) est en rupture de stock pour une période indéterminée, va falloir être créatif. Je trouve logo et nom sur internet et après un petit coup de PhotoFiltre, j’imprime le logo sur papier calque et la plaquette sur papier blanc. Insérée entre 2 carrés de plexiglas, l’effet de la plaquette n’est pas mal du tout, non ?

Après démontage et nettoyage du plateau et malgré les photos prises au préalable, j’ai du mal à remonter les 2 cibles tournantes, les plots plastiques sont trop bas. Comme il y en a de 2 hauteurs différentes j’ai dû en confondre quelque part. Pourtant les décors sont bien placés et de niveau partout, mais comme certains plots ne sont déjà plus d’origines, je soupçonne un problème depuis le départ. En rajoutant de petits écrous j’élève le niveau des cibles tournantes, et plus elles sont hautes, mieux elles prennent l’énergie au passage de la bille et tournent vite et longtemps. Il faut néanmoins ne pas les « monter » trop sinon on n'arrive plus à remettre la vitre ! La marge de manœuvre n’est que de quelques millimètres.

Les contacts de bumpers et de slingshots n’ont pas de condensateurs, j’en rajoute pour donner un peu plus de réactivité, mais je constate beaucoup de contacts fantômes et même des réactions  erronées de la part du processeurs :  le contact du slingshot de droite déclenche le slingshot de gauche !!! Décidément, ces condensateurs donnent des résultats imprévisibles, sur certaines machines ça marche sur d'autres pas, finalement je les enlève.

Et voilà, une belle machine qui revient de loin, prête à recommencer une nouvelle vie de jeu au domicile d’un particulier ou ailleurs.

Ci-dessous, quelques détails de la vitre du fronton : je ne sais pas pourquoi mais les dessinateurs étaient beaucoup plus doués pour dessiner des jolies filles que des ours ! Détail amusant : derrière le dessin des 2 gyrophares de la voiture de police, il y a 2 ampoules clignotantes qui animent la backglass et qui sont du meilleur effet !

détail fronton flipper bally night rider détail fronton flipper bally night rider
plateau flipper bally night rider
détail plateau flipper bally night rider détail plateau flipper bally night rider

(CS juin 2013)



2ème Night Rider

Une deuxième machine a été restaurée ou plutôt remontée à partir d'une caisse, d'un plateau et de cartes électroniques reçues de machines différentes. L'ensemble de l'équipement sous plateau a été transféré d'un plateau à l'autre, un sacré boulot. Un afficheur n'affichait qu'un digit. C'est que le transistor haute tension est claqué en court-circuit et donc allume le chiffre en permanence, consomme  un maximum et empêche les autres afficheurs de s'allumer, une panne classique. Sauf que le transistor claqué n'est pas d'origine, un A42 avait été ressoudé au lieu d'un A92 ! Un NPN à la place d'un PNP ... Y a quand même des artistes ....

 A part cela, travail habituel, rien d'autre à signaler.

(CS janvier 2015)