Schmitronic

Réparations d'appareils électroniques vintage



Restauration d'un flipper Williams TriZone (1979)


Fronton flipper Williams Tri Zone
Plateau flipper Williams Trizone
Fronton flipper Williams Trizone sans vitre Carte MPU flipper Williams Trizone Alimentation flipper Williams Trizone

Rien de spécial à dire, je ne peux que confirmer :

Dans cette machine, il a fallu faire un peu le ménage dans la partie alimentation, on voit sur la photo de droite de gros connecteurs, un disjoncteur, des sucres de connexions ...



2ème machine

Et encore un Trizone, un ! La carte MPU a été révisée. Je vérifie la masse et les autres câblages. La plaquette de support des fusibles GI et d'alimentation est abimée, j'ai même l'impression que les pinces des fusibles touchent la feuille métallique du fond de fronton, je remonte la plaquette sur des entretoises isolantes et remplace un des supports.

On voit le manque d'isolation à l'arrière de la plaque porte-fusible

L'autre chose qui me frappe, c'est la manière dont toutes les belles cartes révisées ont été remontées : avec de longues vis à bois ! La MPU n'est pas plaquée contre les pattes de support et ne repose pas dans le rail inférieur de soutien. Et donc le grand connecteur intercarte tient par lui-même et est soumis aux tensions mécaniques ! Cela ne peut jamais être fiable. Je remets vite des vis conformes.

Quel horreur de remontage !

Le transfo est câblé en 220V je réfléchis à le recâbler en 240V mais c'est impossible l'enroulement intermédiaire est claqué ! J'ai l'impression que cette machine a été assez mal traitée. La suite me le confirmera bien. Une fois tous les fusibles, câblage et alimentation mis en ordre je démarre la MPU : rien ! Pour une carte révisée, c'est ennuyeux. Au banc d'essai l'horloge de la MPU fonctionne, les 2 LEDs aussi (eh oui, il faut les vérifier aussi !). Processeur et contrôleur entrée/sortie sont OK, j'installe la ROM de test de Léon et je finis par détecter que l'IC7 7404 (transmission de signaux logiques vitaux) est grillé. Après remplacement la MPU respire et fonctionne.

Je vérifie toutes les bobines et remonte une des bobines de reset qui pendouille. L'affichage a quelques soucis, je serai obligé de remplacer un des afficheurs esclave. Bizarrement la tôle du fond du fronton n'est pas reliée à la masse alors qu'elle touche la plaque du bas qui est bien à la masse ! Je remets une tresse de masse entre les 2 tôles pour assurer une bonne liaison électrique. Il me faudra remplacer des diodes cassées de la matrice de contact, même le contact de test ne fonctionne plus !

En mode test je constate que le Slam Switch est vu fermé en permanence alors que le contact n'est même plus connecté ! En fait toute la ligne 2 a tous ses contacts fermés ... finalement c'est l'U17 qui pilote la matrice de contact qui a une ligne claquée. Des faux contacts dans les connecteurs empêchent le Knocker et le Bumper du bas de fonctionner, il faudra que je remplace une diode du prédriver de la carte solénoïde pour réactiver le Kicker droit.

Les batteurs sont mous et non conformes. Je règle au plus porches le contact de fin cde course (EOS), change les ressorts et les fourreaux et nettoie les plongeurs, mais cela ne suffit pas. En fait Willimas a prévu des bobine puissante à très faible impédance (1,5 ohm !) qui provoque donc quasi un court-circuit à chaque activation. Ce type de bobine est assez rare et elles coûtent donc assez chers, mais rien à faire, il faut investir dans des neuves. Une fois reçues et montées, il n'y a pas photo, ça claque !

La carte son fonctionne mais il y a un bruit de fond gênant. Je nettoie et ressoude correctement le potentiomètre de volume dans la caisse et règle le trimpot sur la carte à fond. Je vérifie les condensateurs sur la carte son mais comme elle a été révisée, ils sont tous neufs. L'effet ressemble à une "boucle de masse", plusieurs masses de mauvaises qualité arrivent à la carte et induise un ronflement parasite. Comme la carte est à la masse via ses vis de fixation, à tout hasard j'enlève la cosse de masse dans le connecteur d'alimentation (+ et - 15V AC) et hop silence total ! C'était donc bien une belle boucle de masse !

La machine possède 4 cibles tombantes ... mon dieu les cibles tombantes de Williams sont une catastrophe de design ! Une lame de plastique tombe, y est fixée une lame de cuivre en forme de fer à cheval à 2 contacts. Les contacts frottent sur une petite plaquette de circuit imprimé, en provoquant un contact "de passage" pour marquer des points et un contact "d'arrivée" qui est en série avec ceux des autres cibles et qui signale au processeur que les 4 cibles sont tombées et qu'il faut les remonter. Les lames sont toutes fortement abimées (tordues ou cassées), je tente bien de les réparer, mais ce n'est pas fiable. Je commande (elles sont difficiles à trouver) des nouvelles et les remplace. Il faut aussi nettoyer les plaquettes. La difficulté est de régler la pression des contacts : soit elle est trop forte et la cible ne tombe plus, soit elle est trop faible et les contacts électriques ne se font pas ! Il me faudra encore nettoyer, redresser et raccourcir le ressort d'un cible récalcitrante pour qu'elle tombe facilement. Quelle galère ces cibles.

L'état déplorable de 3 des 4 lames de contacts des cibles tombantes !

Après installation chez le client, quelques problèmes surgissent : les cibles ne remontent plus, un bumper ne fonctionne plus, un contact ne se fait pas et il n'y a plus d'illumination générale !

Pour les cibles, ce sont 2 fils qui ont cassés à la soudure, les chocs sont tellement violent et les fils tellement vieux que les vibrations "cassent" les brins. Je coupe et refais de bonnes soudures avec tous les brins de quasi tous les fils de cible.

Pour le bumper, de temps en temps il ne réagit pas, donc il faut attendre que la panne apparaisse ! Une fois présente, je touche délicatement toutes les connections et composants sur le chemin jusqu'à détecter que c'est une soudure froide invisible sur une des pattes du transistor de puissance qui fait faux contact ! Un petit décrassage et un coup de fer à souder et c'est fini.

Pour le contact, ben il suffit de le nettoyer !

Pour l'illumination générale, la grosse soudure du fil commun qui ne passe pas par le fusible a lâché suite au transport ! Je refais la soudure ... et ça ne marche toujours pas ! Je vérifie le fusible de 20A, il est vieux, mais il est bon, je l'enlève et je vois qu'il est "grippé", j'en mets un nouveau et c'est parti. En fait, les chapeaux métalliques du fusible étaient rouillés et ne faisaient plus contact !

Fusible rouillé !

Après beaucoup de corrections et réparations la machine fonctionne à nouveau et, ma foi, elle "roule" très bien !

Après, 2 ans, la machine semble avoir quelques soucis. Je reçois le fronton, la carte MPU avait été révisée et une pile bouton avait été installée à la place du boitier de 3 piles AA. Ce boitier devait comme d'habitude être bien oxydé. Comme la mémoire était bien conservée lors de ma restauration, je n'y avais pas touché, ni même regardé. Mais cette fois la pile est plate, elle a gonflé d'ailleurs, ce qui m'intrigue. Une étiquette indique "Replace with rechargeable battery CR2032". Or c'est une pile et non une batterie qui est montée dans le support ! D'habitude chez Williams il y a des piles et une diode dans le circuit pour empêcher l'alimentation de charger la pile. Mais le schéma prévoit un pont de bypass et de fait, mais plutôt que de court-circuiter cette diode, elle a été enlevée et remplacée par une résistance de 330 ohms, parfait donc, on peut et doit mettre une batterie. Juste pour info, une pile bouton avec la diode ne fonctionne finalement pas très bien, car au lieu de 4,5V donné par 3 piles AA en série une CR2032 ne donne que 3V, moins 0,6V de chute sur la diode, ce qui ne ferait que 2,4V pour alimenter la RAM, on est vite trop juste. De plus, en moyenne les piles AA ont une capacité de 2000 mAh alors qu'une batterie CR2032 de 3,6V aura tout juste 230 mAh. Si on part du principe que les piles durent 5 ans, la pile bouton ne durerait que 6 mois, et encore.

En cherchant à acheter une vraie batterie sur Amazon, je constate que c'est le souk. Alors qu'en français on fait la distinction avec les termes pile et batterie, en anglais on a "battery" pour une pile et "rechargeable battery" pour une batterie ! Et avec la traduction automatique Amazon propose des "piles" qui sont appelées "batteries", ce qui est faux et dangereux ! Quelle confusion, comme quoi les concepts différents doivent toujours être bien nommés différemment. Donc il ne faut pas faire attention à l'annonce mais regarder la photo, on doit y lire clairement "Rechargeable Battery LIR CR2032 3,6V". Sinon c'est une pile.

Sur la carte solénoid il y a pas mal de résistances de puissance qui chauffent vraiment beaucoup et ici sur le groupe de 8 résistances, une ne tient plus que par un fil et une autre manque ! Et toutes les autres sont comme affaissées vers le bas. Qu'est-ce que c'est que ça ? Puis ça fait tilt (si j'ose dire !) : les résistances chauffent tellement que la température des 2 fils monte tellement que l'étain des soudures fond ! Et donc les résistances commencent par s'affaisser puis soit elles tombent d'un coup ou encore un fil se défait, pas de courant, plus de chaleur, la soudure restante redurcit et la résistance reste pendue à un de ses fils ! Seule solution : installer un ventilateur de PC ! Il tourne en 12V, qui est facilement accessible sur la carte alimentation montée juste à côté.

A gauche : une patte dessoudée et une résistance tombée ! A droite, le ventilo installé !