CSPROJECTS

Réparations d'appareils électroniques vintage



Réparation d'un juke-box Rock-Ola 478 Mystic de 1978

Arrive le 1er exemplaire d'une série de 3 machines Rock-Ola 478 Mystic, leur version électronique. De fait, il y a plusieurs boitiers montés un peu partout et des afficheurs ! De base la machine fonctionne, mon partenaire a dégraissé la mécanique, mais tous les afficheurs restent éteints.

Je commence par configurer la machine en 240V (au lieu du 220V habituel), un simple pontage est à modifier dans le bloc alimentation, une étiquette donne toutes les infos nécessaires. Sur chaque boitier se trouve une LED qui indique si l'alimentation est OK. Celle du -21VDC utilisée entre autres pour les afficheurs ne s'allume pas. Bizarrement le schéma des l'alimentation ne se trouve pas dans les manuels et nulle part ailleurs sur internet, je finis quand même par trouver une photo postée sur un forum avec une résolution suffisante, ouf ! Ce schéma, me permettra  de détecter un cosse sortie de son logement et que le disjoncteur 25VAC intervient dans le circuit de production du -21VDC ... et avait sauté. Youpie les petits afficheurs bleus se réveillent !

Schéma alimentation (Source forum flipper-france)

Il y a tout un système digital de collecte des numéros des disques joués, l'originalité dans cette machine est que les numéros des 3 sélections les plus fréquemment jouées sont affichés en permanence sur le fronton de la machine ! Je ne sais pas si cette info provoquait une promotion commerciale supplémentaire ? La mémoire de cette carte électronique possède une batterie ... qui est morte depuis longtemps. Je la remplace par une petite batterie bouton.

Je passe à la partie audio, je teste les hautparleurs, ils sont OK. Par contre la tête de lecture (et l'aiguille !) manque. Avant de commander du neuf, je monte une ancienne tête Shure M44 avec son aiguille. Quelque chose me perturbe et il me faut un peu de temps pour comprendre qu'il y a normalement un pivot vissé sous le bras qui lui permet de glisser sur une surface plane et ainsi conserver le bras à l'horizontal. Or ici ce pivot a disparu, et je dois faire très attention de ne pas lancer un sélection sinon le bras (et sa mécanique d'entrainement) mal positionnée irait se fracasser contre le plateau du tourne-disque. Comme nous avons 3 machines, je remets le pivot d'une autre machine, en attendant de fabriquer un nouveau pivot. La sélection du disque, son transfert et la pose du bras s'effectuent normalement, seul le point entrée de l'aiguille est complètement faux, elle se pose au milieu du disque ! Mais c'est très facile à régler, une vis à défaire (qui l'était déjà) et une articulation (bien grippée) à régler correctement et le problème est réglé.

Au milieu, la vis de blocage de l'articulation pour régler le point d'entrée du disque. A gauche la carte "rajoutée" anti-parasite

Sur plusieurs boitiers, on voit le connecteur monté sur une petite carte qui s'enfiche dans le boitier (voir photo ci-dessus) ! Vu les cartons de protection et les scotchs, c'est un rajout assez peu professionnel. J'ai lu quelque part que Rockola a eu beaucoup de problèmes avec l'électricité statique et autres parasites et ils ont dû bricoler ces cartes de filtrage et de protection pour régler le problème. Mais vu le poids des connecteurs maintenant en porte-à-faux, ils ont dû avoir bien d'autres problèmes de contacts par après ... Pas facile de fiabiliser l'électronique, même si cela fonctionne au labo, dans un monde réel c'est une autre histoire. 

Au niveau audio, le son sort ... mais très mal ! Un fort bruit de souffles et de craquements. Je dépose l'ampli et le fait fonctionner au banc d'essai (c'est plus compliqué qu'avec les amplis Seeburg). Les causes de bruits sont nombreuses : condensateurs de filtrage, ou d'étages, transistors, connecteurs et même transistors, tout quoi ! D'abord à l'oscillo, je constate qu'un canal est bon et je mesure que le bruit provient du préampli d'un des 2 canaux, ce qui réduit déjà de beaucoup les possibilités. Ensuite je "toque" chaque connecteur et composant du préampli ... oups le tapotement sur l'IC de l'ampli OP fait changer le niveau du bruit, bongo ! Je le sors de son support, nettoie les 8 pattes de l'IC et injecte du nettoyant contact sur son support. Problème réglé.

Le résultat est nettement meilleur, mais le son manque de punch et il y a de la distorsion autant dans les basses que dans les aigües. J'injecte un signal sinusoïdal à l'entrée, un canal fonctionne parfaitement mais l'autre ne donne qu'une demi-onde bien visible à l'oscillo ... Chouette distorsion si je n'ai que la moitié du signal ! Comme le préampli fournit des signaux bien propres, c'est forcément la carte driver qui a un souci. De fait, un condensateur est penché, il est sorti de sa base en caoutchouc, il a explosé par le dessous ! Les pinces d'un support de fusible sont vertes d'oxydation (pourtant il n'y a pas de piles dans le coin), c'est le fusible de l'alimentation négative de la carte driver fautive et le contact est évidemment mauvais, la carte est mal alimentée. Je remplace ce qu'il faut et j'obtiens 2 belles sinusoïdes à l'écran ! Yes !

L'amplificateur ouvert et le condensateur "penché" qui a fait "pfuit" !

Maintenant que l'amplification est bonne j'entends que le disque tourne trop lentement et ralentit encore plus par moment ! Pas le choix, c'est l'axe du moteur qui est grippé, il faut tout démonter. Il y a quelques vis, le plus dur est de faire passer le gros condensateur soudé sur la fiche du moteur à travers l'alvéole de la plaque du châssis (encore un composant rajouté par après ...). Un des 4 boulons qui maintient le moteur ensemble est lâché ! Je démonte, nettoie, remets de l'huile surtout dans le feutre du palier inférieur qui n'en reçoit jamais. Ce moteur est bien fait, le palier supérieur est constitué d'un bille percée et non d'une bague, ce qui permet un mouvement de rotule. Le truc est de resserrer les 4 boulons "en diagonale" et en plusieurs fois, en vérifiant à la main que l'axe tourne très facilement, comme une toupie (5 sec = OK, 1 sec= not OK !). Je remonte le tout et hop, le 45t/m est de retour ! Ah ces vieilles mécaniques, quel plaisir.

Il me reste encore à remplacer la batterie du "records tracker" qui permet entre autres d'afficher sur le panneau avant le hit parade des 3 disques les plus demandés et de mettre la machine en crédit gratuit. Il suffit de mettre les DIP switches D1, D2 et D3 à off, c'est bien documenté.

Pour mettre en crédit gratuit suivre la flèche !
Belle machine, originale avec ses 3 afficheurs qui donnent le hit parade !